Third-party issue: DHL PARCEL GB - Label announcement issues

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 23:33 CET

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 17:40 CET

Investigating

We are currently investigating an issue preventing users from announcing labels.
Posted Oct 29, 2025 - 17:39 CET
This incident affected: Affected market (UK) and Carriers (DHL Parcel GB).