Third-party issue: DHL Express - Label announcement issues

Incident Report for Sendcloud

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 16:16 CEST

Investigating

We are currently investigating an issue preventing users from announcing DHL Express labels.
Posted Apr 08, 2026 - 13:19 CEST
This incident affects: Affected market (GLOBAL) and Carriers (DHL Express).