Social Login via Google and Facebook is currently unavailable
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 20:04 CET
Update
Google and Facebook are currently having issues with their services and login to Sendcloud using Social Login is currently unavailable.
You can login to your Sendcloud account using your email address.
Posted Mar 05, 2024 - 17:12 CET
Investigating
Google is currently having issues with their services and login to Sendcloud using Google is currently unavailable.
You can login to your Sendcloud using your email address.
Posted Mar 05, 2024 - 17:01 CET
This incident affected: Sendcloud (Sendcloud Panel) and Affected market (GLOBAL).