SEUR - Problema al generar etiquetas | Label announcement issues
Incident Report for Sendcloud
Resolved
Esta incidencia se ha resuelto.

This issue has been resolved.
Posted Jul 17, 2024 - 15:35 CEST
Investigating
Actualmente estamos investigando esta incidencia.

We are currently investigating this issue.
Posted Jul 17, 2024 - 11:36 CEST
This incident affected: Carriers (SEUR).