Third-party issue: Spring - Label announcement issues

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 15:19 CET

Monitoring

"The carrier seems to be recovering, and we are observing that users are able to create labels again. We will keep monitoring."
Posted Nov 28, 2025 - 15:12 CET

Investigating

We are currently investigating an issue preventing users from announcing labels.
Posted Nov 28, 2025 - 14:50 CET
This incident affected: Affected market (GLOBAL) and Carriers (Spring).