[DPD] Problems announcing labels
Incident Report for Sendcloud
Resolved
This issue has been resolved.
Posted Jul 25, 2024 - 18:41 CEST
Monitoring
DPD has implemented a fix and we are monitoring the situation.
Posted Jul 25, 2024 - 17:02 CEST
Identified
DPD has identified the problem, and they are working on a fix.
Posted Jul 25, 2024 - 14:11 CEST
Investigating
We are currently investigating this issue.
Posted Jul 25, 2024 - 10:51 CEST
This incident affected: Carriers (DPD).