Sendcloud panel not loading

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 15:03 CEST

Monitoring

We implemented and released a fix. We will continue to monitor the performance to ensure the service is fully restored.
Posted Apr 01, 2025 - 14:22 CEST

Investigating

We are currently investigating an issue with the panel not loading. We apologize for the inconvenience and will provide an update as soon as possible.
Posted Apr 01, 2025 - 13:45 CEST
This incident affected: Sendcloud (Sendcloud Panel).