Third-party issue: DHL eCommerce - Label announcement issues

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 11:43 CET

Monitoring

The issue appears to be resolved by the carrier and we are monitoring the results.
Posted Mar 25, 2025 - 11:01 CET

Identified

The carrier is currently experiencing a partial outage, which is causing the label announcement issues. Their technical team is actively working on the issue as a high priority to resolve it as quickly as possible.
Posted Mar 25, 2025 - 10:16 CET

Investigating

We are currently investigating an issue preventing users from announcing labels.
Posted Mar 25, 2025 - 09:47 CET
This incident affected: Affected market (GLOBAL, NL) and Carriers (DHL eCommerce).