Third-party issue: Spring- Label announcement issues

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 20:10 CEST

Investigating

We are currently investigating an issue preventing users from announcing labels.
Posted Jun 10, 2025 - 17:48 CEST
This incident affected: Affected market (GLOBAL) and Carriers (Spring).