Geodis - Unable to announce labels. Problèmes d'annonce des étiquettes
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 11:40 CEST
Investigating
We are currently investigating the issue.
Nous enquêtons actuellement sur ce problème.
Posted Jul 19, 2024 - 11:41 CEST
This incident affected: Affected market (FR) and Carriers (Geodis).