[DPD Germany] Maintenance on Wednesday the 22nd of October 2025 between 3:30 pm and 5 pm (CEST)

Scheduled for Oct 22, 15:00 - 16:30 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 21, 2025 - 09:38 CEST

Scheduled

DPD Germany will be performing maintenance work on their systems on Wednesday, 22 October 2025, between 3:30 pm and 5:00 pm (CEST).

During this time, DPD Germany’s web services may be available only to a limited extent, and temporary interruptions can occur. After the maintenance window, services will resume as usual.

Please note: Following the maintenance, the font on the parcel label will be updated to a new style to improve readability and appearance.

We are sharing this information on behalf of DPD Germany to help you plan your shipping processes accordingly.
Posted Oct 20, 2025 - 15:51 CEST
This scheduled maintenance affects: Carriers (DPD).