Sendcloud Panel & Support currently unavailable due to an Cloudflare outage

Incident Report for Sendcloud

Resolved

This incident has been resolved
Posted Dec 05, 2025 - 13:02 CET

Update

A fix has been implemented by Cloudflare and we are monitoring the results.
For more information, see: https://www.cloudflarestatus.com/
Posted Dec 05, 2025 - 10:25 CET

Monitoring

A fix has been implemented by Cloudflare and we are monitoring the results.
For more information, see: https://www.cloudflarestatus.com/
Posted Dec 05, 2025 - 10:18 CET

Identified

Cloudflare has acknowledged the issue and is working on it : https://www.cloudflarestatus.com/
Posted Dec 05, 2025 - 10:06 CET

Investigating

The Sendcloud support is currently unavailable due to a Cloudflare maintenance.
Posted Dec 05, 2025 - 09:56 CET
This incident affected: Sendcloud (Sendcloud Panel, Sendcloud website, Sendcloud Email Services, Sendcloud Service points, Tracking page, Sendcloud Chat, Sendcloud Phone).