The incident impacting access to the Sendcloud Panel has been successfully resolved. The Sendcloud Panel is fully accessible, and service stability has been confirmed.
Posted Jan 13, 2026 - 10:12 CET
Monitoring
Access to the Sendcloud Panel has been restored. Our team will continue monitoring the platform to ensure ongoing stability.
Thank you for your patience.
Posted Jan 13, 2026 - 10:03 CET
Identified
The team has identified the issue and is actively preparing a fix. We appreciate your patience and will share further updates shortly.
Posted Jan 13, 2026 - 09:59 CET
Investigating
The Sendcloud panel is currently not accessible. Our technical team is actively investigating the issue and working to restore normal access as quickly as possible.
Further updates will be shared as soon as more information becomes available.
Posted Jan 13, 2026 - 09:46 CET
This incident affected: Sendcloud (Sendcloud Panel).