Phone Support - Internet outage in Eindhoven office

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 11:02 CET

Update

We are continuing to work on a fix for this issue.
Posted Nov 17, 2025 - 11:01 CET

Update

We are continuing to work on a fix for this issue.
Posted Nov 17, 2025 - 10:25 CET

Identified

Due to the issue on the network provider's side, our internet in the office has downgraded performance. Due to this, we are experiencing issues accepting phone calls at our Customer Support.
Feel free to send us email or reach out via messaging.
Apologies for the inconvenience.
Posted Nov 17, 2025 - 09:35 CET
This incident affected: Affected market (BE, ES, FR, IT, NL, UK) and Sendcloud (Sendcloud Phone).