Sendcloud panel loading slow

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 11:15 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2025 - 10:04 CEST

Identified

We have received reports of Sendcloud panel loading slow. We have identified the issue and will soon share details regarding the resolution.
Posted Jul 07, 2025 - 09:37 CEST
This incident affected: Sendcloud (Sendcloud Panel) and Affected market (GLOBAL).