Sendcloud Panel - Issues accessing the Panel

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:58 CEST

Monitoring

The panel is now accessible via https://panel.sendcloud.nl/.

We will continue to monitor the situation closely to ensure stability and prevent any further issues.
Posted Oct 20, 2025 - 11:07 CEST

Update

The issue has been identified, and our engineering team is actively working on a fix.

Updates will follow.
Posted Oct 20, 2025 - 09:36 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 09:18 CEST

Investigating

We are currently investigating an issue preventing users from accessing the Sendcloud Panel via specific url.

Access is not possible via:
https://panel.sendcloud.com/
https://panel.sendcloud.nl/

Access is possible via:
https://app.sendcloud.com/
https://panel.sendcloud.sc/
http://sendcloud.com/
Posted Oct 20, 2025 - 08:34 CEST
This incident affected: Sendcloud (Sendcloud Panel) and Affected market (GLOBAL).