Incident with our ticket and support system
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 11:39 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2024 - 11:17 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 14, 2024 - 10:56 CET
Identified
Users may encounter issues when contacting our support channels, and there may be a delay in responding to support tickets.

Our team is diligently working to restore the system.

Updates will follow.
Posted Nov 14, 2024 - 10:24 CET
This incident affected: Sendcloud (Sendcloud Chat, Sendcloud Phone).