Phone support temporarily unreachable

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:21 CEST

Monitoring

Phone support service is now back online. Our team has resolved the issue, and you can reach us via phone as usual.
Posted Oct 20, 2025 - 11:45 CEST

Investigating

We are currently investigating an issue with our ticketing system that is preventing users from contacting us via phone. We’ll provide an update once more information is available.
Posted Oct 20, 2025 - 09:40 CEST
This incident affected: Sendcloud (Sendcloud Phone).