[External] Cloudflare System Status issue - Parcel announcement performance low

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 09:27 CET

Monitoring

A fix has been implemented and Cloudflare indicates that the incident is now resolved.

Sendcloud will continue to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 16:08 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 15:01 CET

Investigating

Cloudflare is currently experiencing issues that are impacting the performance of most carriers. Their team is actively investigating the situation. In the meantime, you may notice reduced performance. For more information, please refer to:

https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 13:10 CET
This incident affected: Affected market (GLOBAL).