Third-party issue: [Etsy] - Order import issues

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 17:32 CET

Investigating

We are currently investigating an issue preventing orders being imported and feedback being processed from Etsy integrations.
Posted Nov 28, 2025 - 16:59 CET
This incident affected: Affected market (GLOBAL) and Integrations (Etsy).