Inbound Call Issues

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 10:24 CET

Investigating

We are currently investigating an issue affecting our phoneline support service where incoming calls are not being routed correctly. As a result, some users may experience extended wait times or become stuck in the queue.

We will provide updates as more information becomes available
Posted Mar 02, 2026 - 10:00 CET
This incident affected: Affected market (GLOBAL) and Sendcloud (Sendcloud Phone).