Etsy – Degraded Performance

Incident Report for Sendcloud

Resolved

This incident has been resolved.

Should the issue appear again, please reach out to our support teams and we will resume investigating with Etsy.
Posted Aug 15, 2025 - 17:10 CEST

Update

We are actively investigating with Etsy to identify the issue. We will continue to keep you informed and share any new updates as soon as they are available.
Posted Aug 14, 2025 - 17:26 CEST

Update

We continue to investigate the issue with Etsy and we will share further updates as soon as they are available.
Posted Aug 14, 2025 - 11:49 CEST

Investigating

We are currently investigating an issue causing errors and delays affecting Etsy integrations, including order imports and other related functionalities.
Posted Aug 13, 2025 - 16:15 CEST
This incident affected: Affected market (GLOBAL) and Integrations (Etsy).