Scheduling pickups for FedEx and UPS on 7.4.2026.

Incident Report for Sendcloud

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 17:23 CEST

Investigating

We're currently experiencing an issue with scheduling pickups for today (7 April). Pickups for other dates are not affected and work as expected.

Our team is actively investigating and we'll keep you updated. We apologize for the inconvenience.
Posted Apr 07, 2026 - 14:22 CEST
This incident affected: Affected market (UK) and Carriers (FedEx, UPS).