Monitoring
A fix was implemented for the issue where Mondial Relay service points are not visible on the service point map, and we are currently monitoring the results
Investigating
We are currently investigating an issue where the Mondial Relay service points are not visible on the service point map anymore.