Resolved
This issue has been resolved.
Monitoring
We implemented and released a fix. We will continue to monitor the performance to ensure the service is fully restored.
Investigating
Some users are currently unable to complete the onboarding process. When submitting their details, an error message "We couldn't save your information" may appear.
Our team is investigating and working on a resolution. We apologize for the inconvenience.
Investigating
Some users are currently unable to complete the onboarding process. When submitting their details, an error message "We couldn't save your information" may appear.
Our team is investigating and working on a resolution. We apologize for the inconvenience.