Sendcloud

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Third-party issue: DHL Parcel GB - Label announcement issues
Resolved·Full outage

This incident has been resolved.

Tue, Apr 7, 2026, 01:32 PM
(2 months ago)
·
Affected components
Apr 7, 2026, 10:44 AM
01:32 PM
Updates

Resolved

This incident has been resolved.

Tue, Apr 7, 2026, 01:32 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Tue, Apr 7, 2026, 11:41 AM(1 hour earlier)

Investigating

We are currently investigating an issue preventing users from announcing labels.

Tue, Apr 7, 2026, 10:44 AM(57 minutes earlier)