Resolved
This incident has been resolved.
Investigating
We are currently investigating an issue affecting our phoneline support service where incoming calls are not being routed correctly. As a result, some users may experience extended wait times or become stuck in the queue.
We will provide updates as more information becomes available